Instalación y Uso de la Aplicación ALIEN en UBUNTU

¿Qué es ALIEN?

 Es un programa convertidor de paquetes de Linux.

¿Para qué sirve ?

 Algunas distribuciones Linux, como por ejemplo Red Hat, SUSE y Mandriva, usan paquetes rpm, organizados de manera diferente a los paquetes deb de Debian y Ubuntu como es la extensión .rpm. Si  buscas un archivo en formato .deb y no encuentras mas que el .rpm de esas distribuciones tendrías que convertir ese paquete de .rpm a .deb y esto es lo que hace el programa ALIEN.

Formatos: .rpm  .tar.gz   .deb


1. Instalación de ALIEN 

Podemos instalar ALIEN de 2 formas:

-Mediante el Gestor de paquetes Synaptic
-Terminal 


1.1. Instalación de ALIEN en el Gestor de paquetes Synaptic

Abrimos el gestor de paquetes synaptic ya sea buscándolo o desde la terminal poniendo 

sudo synaptic 


Ahora buscaremos el programa alien y vemos que nos aparece el primero con su descripción:


Lo marcaremos y nos saldrá un mensaje sobre que se marcarán otros paquetes relacionados con alien y el rpm.


Como vemos mas abajo rpm tambien se nos ha marcado para instalar, solo tendremos que dar luego a Aplicar y listo.




1.2. Instalación de ALIEN mediante terminal de comandos

Es tan sencillo como poner en el terminal:

sudo apt-get install alien



2. Convertir archivos con ALIEN 


Convertir .rpm a .deb --> Supongamos que el paquete a convertir se encuentra en el escritorio, hacemos:


cd Escritorio
sudo alien -d nombre_archivo.rpm y se generará el paquete deb

Convertir tar.gz a .deb  --> Supongamos que el paquete a convertir se encuentra en el escritorio, hacemos:


cd Escritorio
sudo alien nombre_archivo.tar.gz y se generara el paquete deb


* Si queremos ver las opciones de alien podemos poner en terminal :

sudo alien



Una vez generado el archivo deb tan solo le damos dos clics encima y le damos a instalar paquete.

Comentarios

  1. No puedo instalarlo cuando lo voy a instalar me solicita lo siguiente:
    Introduzca el disco con la etiqueta:
    Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release i386 (20130213)

    ResponderEliminar
  2. Disculpa amigo, trato de instalar sql developers en lubuntu 12.10 y al seguir tus pasos, cuando debería convertir, me marca lo siguiente:

    Warning: Skipping conversion of scripts in package sqldeveloper: postinst
    Warning: Use the --scripts parameter to include the scripts.


    ayuda!!!!!!! porfa no se que hacer

    ResponderEliminar
    Respuestas
    1. Que escribes para convertir el paquete?

      Eliminar
    2. Hola!!!! tengo el mismo problema, escirbo sudo alien -d

      Eliminar
  3. Muy buen tutorial, hacen falta muchos más así, para "la gente normal" me refiero a los que apenas empiezan o tienen curiosidad por usar Linux.

    ResponderEliminar
    Respuestas
    1. Gracias Allen, eso intento porque yo por ahi me vuelvo loco con algunos tutoriales, se creen que somos todos profesionales. Yo intento explicarlo para principiantes como yo.

      Me alegro que te haya sido de ayuda amigo. Saludos.

      Eliminar
  4. hola, el deb que creas a partir del .tar.gz cuando lo instalas a que carpeta va?

    ResponderEliminar
  5. excelente aporte, gracias, yo lo descargue ayer en casa y hoy en el trabajo, saludos

    ResponderEliminar
  6. Muchas gracias por tu aporte me vino exelente

    ResponderEliminar
  7. Porque cuando pongo sudo apt-get install alien me sale E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

    ResponderEliminar
  8. Genial che, gracias! Es dificil encontrar post donde lo expliquen tan bien para lxs que no la tenemos clara todavía.
    Saludos!

    ResponderEliminar

Publicar un comentario

Entradas populares de este blog

Crear USB bootable de Ubuntu en Windows

Instalar Java + Plugin en Ubuntu